Ftax Requirements

Ftax requires the following:

  • Adobe Reader 7, 8, 9, X or XI (click here to download Adobe Reader for free). Please note: Reader 9.1 is not suitable.
  • Microsoft Windows 2000, XP, Vista, 7, 8, and 10, most versions of Apple Mac, and some versions of Linux. For a full list of requirements for Reader 7 or above, see www.adobe.com .
  • An Inland Revenue User ID and Password to file online (click here if you need to register).
  • Compliance with the Special Notice displayed when the SA100 is first opened, and on the SA800 and CT600 submit pages.
  • Users who have downloaded Reader 9.3.2 or above are required to go to Edit > Preferences > Security (Enhanced) and untick the 'Enable enhanced security' box ( Adobe Reader > Preferences > Security (Enhanced) if you are using a Mac).
  • Internet Explorer 7+ or (current versions of) Firefox, Chrome, Safari or Opera.
  • Ftax does not currently work on tablets.

Ftax Records

iXBRL

  • iXBRL Ready Now!
    Here is what you need to do

    A quick and (very) easy guide to iXBRL [More Details]

Free Downloads

We accept the following cards:

Company Tax | Partnership Tax | Self Assessment Tax